7-6: The Schematic Technology


Digital Schematics

The Schematic technology allows you to design using digital schematic components. To obtain this technology, use the Change Current Technology... command of the Technology menu and select "schematic, digital".

Figure 7.3
There are two arcs in the Schematic technology: the wire (blue) and the bus (green). These arcs can be drawn at 45 degree angles. One typically names busses with array names (for example "insig[0:7]"), and then names wires with scalar names (for example "insig[1]"). See Section 6-9 for more on bus naming. To make a physical connection of a wire to a bus, the bus pin can connect to either, so it acts as a tap. In addition, the Wire Con node connects wires to busses, or connects busses of different width, replicating the narrower side to make it as wide as the wider side. Use the Rip Bus Signals subcommand of the Network command of the Tools menu to automatically add taps to a bus.

Digital schematics are built with the And, Or, Xor, Buffer, Multiplexor, and Flip-Flop nodes that appear in the component menu. By attaching arcs to these components and negating them (with the Negated command of the Arc menu), these turn into NAND, NOR, Inverter, and many other specialized components. Note that the size of the negating bubble can be controlled by using the Technology Options... command of the Technology menu and setting the "Negating Bubble Size" value in the "Schematics" section.

The And, Or, and Xor nodes can accept any number of input connections on the left, so they require some care in wiring. The left side has one large input port that allows an arbitrary number of connections. Initially, wires may attach at only three input locations, spaced evenly along the left side. However, when all three locations are connected, the node automatically expands, adding additional space along the side for new arcs. The Multiplexor node also has a variable-sized port on the left side.

To properly wire inputs to an And, Or, Xor, or Multiplexor node, cursor placement is very important, for it determines which of the locations to use on the left side. If an arc gets connected in the wrong location, try connecting more arcs until one appears in the right place, and then delete the unwanted ones.

Analog Schematics

To do analog schematic design, use the Change Current Technology... command of the Technology menu and select "schematic, analog". The component menu will present a selection of analog schematic nodes. Even without switching to this technology, analog components are always available from the New Analog Part and New SPICE Part commands of the Edit menu.

Figure 7.4
The analog nodes can have user-settable values displayed on them. When a node is created, you may be prompted for an appropriate value.

Transistors can be 3-port or 4-port (with bias), and are switched with the "3-Port" and "4-Port" entries.

The Switch node can take an arbitrary number of poles. Simply stretch it along the line of the poles and their number will grow. To do this, use the Size command of the Edit menu.

The "Spice" entry presents a popup menu of Spice parts (the same as is found in the New SPICE Part command). More information about the use of these parts can be found in the Section 9-4.

The "Inst." entry presents a popup menu of all cell instances.

The "Global" node defines a global signal name that spans levels of hierarchy (see Section 6-9).

The Resistor can be treated as a connecting or nonconnecting node. By default, it does not connect the networks on its two ends, and this is the correct way to treat it when doing low-level simulation such as SPICE. However, for higher-level simulations (such as Verilog) the resistor should be ignored and treated as if it connects its two networks. To make this happen, use the Network Options... subcommand of the Network command of the Tools menu and check "Ignore Resistors". Note that if resistors are being ignored, SPICE deck generation will temporarily include them while the netlist is being created.

Some commands that analyze a schematic circuit need to know which layout technology will be used to fabricate the design. For example, when generating a SPICE deck from a schematic, it is necessary to know the sizes and parasitics that are associated with the actual circuit. To set the layout technology to use for schematic circuits, use the Technology Options... command of the Technology menu and set the "Use Lambda values from this Technology" field.

Multipage Schematics and Frames

Multipage schematics are provided in Electric by having different views for each page. Thus, you can have cells called "Timer{p1}" and "Timer{p2}" which are pages 1 and 2 of the Timer schematic. To create these cells, use the Edit Multi-page Schematic View... command of the Views menu.

As a graphical aid to schematic design, frames can be displayed in a cell by using the Frame Options... command of the View menu.

The "Half-A", "A", "B", "C", "D", and "E" size frames are available in both landscape and portrait mode. You can also choose to display a title box in the lower-right corner.

Figure 07-20
In the title box, the cell name and date are shown. You can also add information about the designer, company, and project. This information can be set as a default for all design, and can be overridden on a per-library basis.

Prev Previous     Contents Table of Contents     Next Next