6-3: Options


There are many commands in Electric that set options. These commands customize the system for your use. Here is a list of commands that set options, with references to them:
File menu:Library Options, Copyright Options [3-9], CIF Options, GDS Options, EDIF Options, DEF Options, CDL Options, DXF Options, SUE Options [7-3] (IO Options submenu)
Print Options [4-9]
Edit menu:New Node Options [6-2]
Selection Options (Selection submenu) [2-1]
Cell menu:Cell Options [3-7]
Arc menu:New Arc Options [5-5]
Export menu:Port and Export Options [3-6]
View menu:Frame Options [7-6]
Icon Options [3-12]
Windows menu:Grid Options [4-7]
Alignment Options [4-7]
Layer Visibility [4-5]
Color Options (a submenu) [4-6]
Layer Display Options [4-6]
Text Options [6-8]
3D Options (3D Display submenu) [4-11]
Messages Window Location [4-2]
Info menu:General Options (User Interface submenu) [9-1]
Quick Key Options (User Interface submenu) [1-9]
Technology menu:Technology Options [7-1]
Change Units [7-2]
Tools menu:DRC Options, DRC Rules (DRC submenu) [9-2]
Simulation Options (Simulation (Built-in) submenu) [10-2]
Spice Options (Simulation (SPICE) submenu) [9-4]
Verilog Options (Simulation (Verilog) submenu) [9-4]
FastHenry Options (Simulation (Others) submenu) [9-4]
Well Check Options (ERC submenu) [9-3]
Antenna-Rules Options (ERC submenu) [9-3]
NCC Control and Options (Network submenu) [9-6]
Network Options (Network submenu) [6-9]
Logical Effort Options (Logical Effort submenu) [9-12]
Routing Options (Routing submenu) [9-5]
VHDL Options (VHDL submenu) [9-10]
Silicon Compiler Options (Silicon Compiler submenu) [9-9]
Compaction Options (Compaction submenu) [9-11]
Java Options [11-1]

These options are stored in a file called "electricoptions.elib" in your "lib" directory (on UNIX, the file is stored in "~/.electricoptions.elib"). Deleting this file will cause your options to revert to the default state set by Electric.

Options are saved when Electric exits. To save the options sooner, use the Save Options Now subcommand of the Option Control command of the Info menu.

To see which options are being saved, use the Examine Saved Options... command. This not only lists the options that are being carried between each session, it also shows which ones have been changed in this session.

To help find options, use the Find Options... subcommand of the Option Control command of the Info menu. This presents a list of all option commands and lets you search it by keyword.

There are times when you want to save options with a library. For example, a library of standard cells, designed for the Silicon Compiler, will want to store Silicon Compiler options in it so that the user of the library can have the proper options set.

To request that a set of options be saved with the current library, use the Saving Options With Libraries... subcommand of the Option Control command of the Info menu. Select the options that you want saved and then save the library. When this library is read in, options in that library will override the current settings.

Figure 6.11

Prev Previous     Contents Table of Contents     Next Next